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Android Disconnects & Reconnects Constantly in Windows Phonecheck
Android Disconnects & Reconnects Constantly in Windows Phonecheck

Android device connecting and disconnecting in Phonecheck desktop

Updated over a week ago

Cause:

  • HTC Sync Manager uses ADB to communicate with Android devices on the computer.

  • When running multiple ADB processes it will cause Phonecheck desktop to experience this issue.

Solution:

  • Open control panel

  • Uninstall HTC Sync Manager

  • Restart the computer.

Note: If this didn't resolve your issue you may want to continue below for additional troubleshooting.

Other Reasons

  • USB Debug isn't enabled

  • Not using OEM cables

  • Hub isn't providing proper power

  • Too many devices connected to the same power source or multiple power strips connected to each other.

  • Android device is not showing in Phonecheck or under device manager

How to Troubleshoot

  • Try switching to a known working cable from another station, also try a different port.

  • Try switching to a known working USB hub from another station.

  • Verify you have clean power to the computer and its hardware. If you have multiple power strips connected, try to eliminate them to only use 1 single strip.

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